Back to overview
Degraded

Slow response times across the backend

Mar 29, 2025 at 12:47pm UTC
Affected services
Backend

Resolved
Mar 29, 2025 at 01:54pm UTC

We've resolved this issue, and improved performance across our services

Created
Mar 29, 2025 at 12:47pm UTC

Our backend experienced degraded performance for about an hour.